Error parsing XSLT file

Dec 3, 2009 at 5:18 PM
Edited Dec 3, 2009 at 5:20 PM

i got error with xslt.

i use "Umbraco Creative Website Starter - 2.0.2"

Error parsing XSLT file: \xslt\Navi.xslt

Error parsing XSLT file: \xslt\NewsEventsSubNavi.xslt

......

 

can anybody help me?

Dec 4, 2009 at 8:52 AM

Hiya David,
These errors are very generic and do not give us any detail to the problem.

To view the full stack trace and error (which will be highlgihted in red, further down the page) you will need to use the following querystring appened to the URL with the error on it: ?umbDebugShowTrace=true

This blog post contains some bookmarklets that you can use in your browser to help add these debug features easilly:
http://www.cpalm.dk/blog/2008/01/20/umbraco-debugging-made-easy.aspx

Report back here what the problem is.

Warren

Dec 4, 2009 at 11:56 AM

Hello Warren,

 

i got following information:

 

the system can not find CommerceForUmbraco.xsltExtensions.dll...

 

 

umbracoMacro InnerException Could not load file or assembly 'file:///D:\Web\Firma\Umbraco 4.0.2.1\bin\CommerceForUmbraco.xsltExtensions.dll' or one of its dependencies. Das System kann die angegebene Datei nicht finden.
Could not load file or assembly 'file:///D:\Web\Firma\Umbraco 4.0.2.1\bin\CommerceForUmbraco.xsltExtensions.dll' or one of its dependencies. Das System kann die angegebene Datei nicht finden.
  at System.Reflection.Assembly.nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection)
  at System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)
  at System.Reflection.Assembly.InternalLoadFrom(String assemblyFile, Evidence securityEvidence, Byte[] hashValue, AssemblyHashAlgorithm hashAlgorithm, Boolean forIntrospection, StackCrawlMark& stackMark)
  at System.Reflection.Assembly.LoadFrom(String assemblyFile)
  at umbraco.macro.GetXsltExtensions()
Dec 4, 2009 at 12:02 PM

Hello David,
It looks like you have installed the CommerceForUmbraco package into the site, which is causing problems.

Basically the problem is that it cannot find the DLL named CommerceForUmbraco.xsltExtensions.dll which should be located in the D:\Web\Firma\Umbraco 4.0.2.1\bin\ folder.

You could try downloading the package to your desktop (which is a normal ZIP file) and unzip the folder and manually copy over the missing DLL from the Commerce for Umbraco package.

Warren

Dec 4, 2009 at 12:33 PM

Hello Warren,

 

thanks for your reply.

Yes, i have unziped the file "Creative_Website_Starter_2.0.2", but it doesn´t have CommerceForUmbraco.xsltExtensions.dll in the package.

Dec 4, 2009 at 12:47 PM

Hello David,
Commerce for Umbraco is nothign to do with my CWS package and is a totally seperate project.

http://our.umbraco.org/projects/commerce-for-umbraco


Warren