Error opening photo gallery

Aug 28, 2009 at 6:13 AM

Hi Warren,

First of all, congratulations on your package.

I'm new to umbraco, i've installed it on a localhost with iis 6 and win xp, and installed the cws on it.

The website works, but when i try to open one of the photo galleries, for example: /gallery/the-bookhouse-boys.aspx, i get a System.Web.HttpException error, saying it doesn't exist or can't be accessed due to security restrictions.

Is this related to the url rewriting?

Thanks again, sorry for my english, speaking from Brazil.

Leonardo Puglia.

Aug 28, 2009 at 9:05 AM

Hi Leo,
I think this is something to do with permissions possibly with your umbraco installation rather than something with CWS.

Please could you give me the full error message as this is hard for me to find what the problem is.

Warren

Aug 31, 2009 at 10:18 PM

Warren,

The error message is in portuguese, a simple translation is:

Server Error on Application '/gallery'.

The server could not access the application directory 'c:\inetpub\wwwroot\gallery\'. It doesn't exist or isn't accessible due to security configurations.

Here is the full error message:

Erro de Servidor no Aplicativo '/gallery'.

Servidor não pode acessar o diretório de aplicativos 'c:\inetpub\wwwroot\gallery\'. Ele não existe ou não está acessível devido às configurações de segurança.

Descrição: Ocorreu uma exceção não tratada durante a execução da atual solicitação da Web. Examine o rastreamento de pilha para obter mais informações sobre o erro e onde foi originado no código.

Detalhes da Exceção: System.Web.HttpException: Servidor não pode acessar o diretório de aplicativos 'c:\inetpub\wwwroot\gallery\'. Ele não existe ou não está acessível devido às configurações de segurança.

Erro de Origem:

Exceção não tratada foi gerada durante a execução da atual solicitação da Web. As informações relacionadas à origem e ao local da exceção podem ser identificadas usando-se o rastreamento de pilha de exceção abaixo.


Rastreamento de Pilha:

[HttpException (0x80004005): Servidor não pode acessar o diretório de aplicativos 'c:\inetpub\wwwroot\gallery\'. Ele não existe ou não está acessível devido às configurações de segurança.]
System.Web.HttpRuntime.EnsureAccessToApplicationDirectory() +8924255
System.Web.HttpRuntime.HostingInit(HostingEnvironmentFlags hostingFlags) +87

[HttpException (0x80004005): Servidor não pode acessar o diretório de aplicativos 'c:\inetpub\wwwroot\gallery\'. Ele não existe ou não está acessível devido às configurações de segurança.]
System.Web.HttpRuntime.FirstRequestInit(HttpContext context) +8886319
System.Web.HttpRuntime.EnsureFirstRequestInit(HttpContext context) +85
System.Web.HttpRuntime.ProcessRequestInternal(HttpWorkerRequest wr) +259



Informações sobre a Versão: Microsoft .NET Framework Versão:2.0.50727.3053; Versão do ASP.NET:2.0.50727.3053

Sep 1, 2009 at 8:26 AM

Hi Leo.
OK how did you install Umbraco?
Is this running locally on your machine, if so are you running Vista, XP, Win7 ?

What version of IIS are you using?

Warren