Error 309 (Provider v. 3.4.1.69): Duplicate key found in index: PK_cmsDataTypePreValues: row#3 :id(4)

Mar 9, 2009 at 8:09 PM
I can't seem to get past this error, been trying for a week now.  Any suggestions?  Help greatly appreciated, from other posts, trying to learn umbraco w/out CWW is debilitating.   :)

xp pro, .net v3.5, installed w/cassini using vistadb, did webconfig mod.  able to install runway, blog, other packages...

Server Error in '/' Application.
--------------------------------------------------------------------------------

Error 309 (Provider v. 3.4.1.69): Duplicate key found in index:  PK_cmsDataTypePreValues: row#3 :id(4)

Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: VistaDB.Diagnostic.VistaDBException:
Error 309 (Provider v. 3.4.1.69): Duplicate key found in index:  PK_cmsDataTypePreValues: row#3 :id(4)

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below. 

Stack Trace:

[VistaDBException:
Error 309 (Provider v. 3.4.1.69): Duplicate key found in index:  PK_cmsDataTypePreValues: row#3 :id(4)
]
   RqHv1e4DGbBT06NT6cx.iu32Bc449ujc8wYuWmB.5Frp2qgRdN(Boolean , Boolean ) +622
   WFM0UqDpmt8PH2Uhwkl.PJijmeDmu7IbbefPvNZ.DoCreateLinkFrom(iu32Bc449ujc8wYuWmB , A4OMsd3qMRCvGXSnpy6 , WdtjBZ3NYW9aMYICskU ) +77
   l47w34DPt17rUNtBwrU.4PQtIDDNxw3dl4BCIxN.DoCreateLinkFrom(iu32Bc449ujc8wYuWmB , A4OMsd3qMRCvGXSnpy6 , WdtjBZ3NYW9aMYICskU ) +58
   RqHv1e4DGbBT06NT6cx.iu32Bc449ujc8wYuWmB.RyEpawu4kB(Qpq6XA3A4AOODKt75MS ) +322

[VistaDBException:
Error 309 (Provider v. 3.4.1.69): Duplicate key found in index:  PK_cmsDataTypePreValues: row#3 :id(4)
Error 254 (Provider v. 3.4.1.69): Cannot create link to:  cmsDataTypePreValues
]
   RqHv1e4DGbBT06NT6cx.iu32Bc449ujc8wYuWmB.RyEpawu4kB(Qpq6XA3A4AOODKt75MS ) +544
   3aie6y3bK6perBpar8b.Qpq6XA3A4AOODKt75MS.Blw4a3RtC(iu32Bc449ujc8wYuWmB ) +51
   RqHv1e4DGbBT06NT6cx.iu32Bc449ujc8wYuWmB.fZmppuKxfG() +196

[VistaDBException:
Error 309 (Provider v. 3.4.1.69): Duplicate key found in index:  PK_cmsDataTypePreValues: row#3 :id(4)
Error 254 (Provider v. 3.4.1.69): Cannot create link to:  cmsDataTypePreValues
Error 255 (Provider v. 3.4.1.69): Cannot create linked data:  cmsDataTypePreValues
]
   RqHv1e4DGbBT06NT6cx.iu32Bc449ujc8wYuWmB.5Frp2qgRdN(Boolean , Boolean ) +622
   QHwxsuvz0OLMibYms4N.vQbcnLvryco6p1el5w8.i3mndMgug(Boolean , Boolean ) +86

[VistaDBException:
Error 309 (Provider v. 3.4.1.69): Duplicate key found in index:  PK_cmsDataTypePreValues: row#3 :id(4)
Error 254 (Provider v. 3.4.1.69): Cannot create link to:  cmsDataTypePreValues
Error 255 (Provider v. 3.4.1.69): Cannot create linked data:  cmsDataTypePreValues
Error 250 (Provider v. 3.4.1.69): Cannot create row: 
Table: 'cmsDataTypePreValues', RowId = 3

]
   xLGbRrKRcyb3TskPYs1.TYtD8HKAEaewEPKXyDD.L9tpSrXsi() +311
   xLGbRrKRcyb3TskPYs1.TYtD8HKAEaewEPKXyDD.NextResult(VistaDBPipe ) +161
   VistaDB.Provider.VistaDBDataReader.tjd0SLXNs(Int64& ) +279
   VistaDB.Provider.VistaDBCommand.JUv4Wj4dg(Int64& ) +182
   VistaDB.Provider.VistaDBCommand.ExecuteNonQuery() +44
   umbraco.DataLayer.SqlHelpers.VistaDB.VistaDBHelper.ExecuteNonQuery(String commandText, VistaDBParameter[] parameters) +81
   umbraco.DataLayer.SqlHelper`1.ExecuteNonQuery(String commandText, IParameter[] parameters) in d:\inetpub\wwwroot\ccnet\Source\Umbraco 4\umbraco\datalayer\SqlHelper.cs:217

[SqlHelperException: Umbraco Exception (DataLayer): SQL helper exception in ExecuteNonQuery]
   umbraco.DataLayer.SqlHelper`1.ExecuteNonQuery(String commandText, IParameter[] parameters) in d:\inetpub\wwwroot\ccnet\Source\Umbraco 4\umbraco\datalayer\SqlHelper.cs:221
   umbraco.cms.businesslogic.datatype.PreValue.Save() +324
   umbraco.cms.businesslogic.datatype.DataTypeDefinition.Import(XmlNode xmlData) +636
   umbraco.cms.businesslogic.packager.Installer.InstallBusinessLogic(Int32 packageId, String tempDir) +163
   umbraco.presentation.developer.packages.Installer.processInstall(String currentStep) +180
   umbraco.presentation.developer.packages.Installer.Page_Load(Object sender, EventArgs e) +336
   System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +14
   System.Web.Util.CalliEventHandlerDelegateProxy.Callback(Object sender, EventArgs e) +43
   System.Web.UI.Control.OnLoad(EventArgs e) +73
   umbraco.BasePages.BasePage.OnLoad(EventArgs e) +16
   System.Web.UI.Control.LoadRecursive() +52
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +2153

 

--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:2.0.50727.3082; ASP.NET Version:2.0.50727.3082

Mar 9, 2009 at 9:30 PM
Hello Tonian sorry to hear you are experincing problems using CWS2 with Vista DB.
Can I recommend you try installing umbraco V4 again and using CWS2 with Microsoft SQL DB whilst I look into this problem.

Warren
Mar 9, 2009 at 9:31 PM
This discussion has been copied to a work item. Click here to go to the work item and continue the discussion.
Mar 9, 2009 at 9:53 PM
Ok, I'll give that a try tonight, that was going to be on my todo list eventually, just wanted to get a bit farther over the learning curve before tossing another level on the project.  Oh well, nothing good comes easy.   :)

Thanks.
Mar 10, 2009 at 6:06 AM
Warren,

That worked fine, thanks.  Was able to just follow the instructions and all went smooth.  BTW, they only list CWS .99 in the Umbraco package Repository.  I had tried that one and v.2 though and neither worked with vistadb for me.  Didn't try .99 with SQL though, just 2.

Thanks again for your help and thanks very much for CWS2, your screen casts, et al.
Mar 13, 2009 at 9:33 PM
This issue is caused by umbraco, not by CWS. A fix allready has been made in the umbraco-source. This will be no longer an issue in umbraco 4.0.1.
Mar 10, 2013 at 5:59 PM