Umbraco, YAF, & CWS

Aug 5, 2010 at 11:14 PM
Edited Aug 5, 2010 at 11:15 PM

I was able to get YAF and umbraco to work together to a degree.  I added the <yaf:forum> tag to a usercontrol and I am trying to get it to display the forum inside of CWS.  CWS seems to be the issue but I am unable to track down exacly where the issue is.  If I use Runway the Forum embeds perfectly!

It has to be one of the scripts that are running with CWS but I can't figure one which one.  Has anyone had this problem

Here is the stack trace

  Server Error in '/' Application.
--------------------------------------------------------------------------------

Object reference not set to an instance of an object.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below. 

Stack Trace:

 

 

 

 

 

[NullReferenceException: Object reference not set to an instance of an object.]
   DNA.UI.ClientScriptManager.RegisterScriptsOnPagePreRenderComplete(Object sender, EventArgs e) +379
   System.EventHandler.Invoke(Object sender, EventArgs e) +0
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +4526
 

--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.1 
Request Details 
Session Id: 4gzg4hdtmwgmfljdqi5tlmuh Request Type: GET 
Time of Request: 8/5/2010 11:56:45 AM Status Code: 500 
Request Encoding: Unicode (UTF-8) Response Encoding: Unicode (UTF-8) 
Trace Information 
Category Message From First(s) From Last(s) 
umbracoGlobalsettings reserverd urls: '/config/splashes/booting.aspx,/config/splashes/nonodes.aspx,/install/,/umbraco/,/yaf/,'   
aspx.page Begin PreInit 0.000530213712568734 0.000530 
umbracoInit handling request 0.000569735935093219 0.000040 
request handler current url '/forums.aspx' 0.000711913281057923 0.000142 
umbracoRequestHandler Just before xPath query (True, '1156') 0.000744762920558793 0.000033 
umbracoRequestHandler After xPath query 0.000767347047715641 0.000023 
umbracoRequestHandler Access checking started 0.00080892237270893 0.000042 
umbracoRequestHandler Page not protected 0.0008417720122098 0.000033 
umbracoRequestHandler Access checking ended 0.000859736658811839 0.000018 
umbracoInit Done handling request 0.000876674754179475 0.000017 
umbracoPage Element loaded: umbracoNaviHide 0.00114511790197565 0.000268 
umbracoPage Element loaded: headerText 0.00119439236122695 0.000049 
umbracoPage Pagedata loaded for Forums (ID: 1156) 0.0012169764883838 0.000023 
aspx.page End PreInit 0.00174873002780414 0.000532 
aspx.page Begin Init 0.00177182743057819 0.000023 
umbracoMacro Macro loaded from cache (ID: 13, [XSLT] Page Title) 0.00294979497205471 0.001178 
renderMacro Rendering started (macro: [XSLT] Page Title, type: 1, cacheRate: 0) 0.00298418443840718 0.000034 
umbracoMacro Before adding extensions 0.00305296337111213 0.000069 
umbracoXsltExtension Extension added: urn:Exslt.ExsltCommon, ExsltCommon 0.00371765529538755 0.000665 
umbracoXsltExtension Extension added: urn:Exslt.ExsltDatesAndTimes, ExsltDatesAndTimes 0.00374331907624761 0.000026 
umbracoXsltExtension Extension added: urn:Exslt.ExsltMath, ExsltMath 0.00376385010093565 0.000021 
umbracoXsltExtension Extension added: urn:Exslt.ExsltRegularExpressions, ExsltRegularExpressions 0.00378232802315489 0.000018 
umbracoXsltExtension Extension added: urn:Exslt.ExsltStrings, ExsltStrings 0.00380080594537413 0.000018 
umbracoXsltExtension Extension added: urn:Exslt.ExsltSets, ExsltSets 0.00382287679691378 0.000022 
umbracoMacro After adding extensions 0.00384084144351582 0.000018 
umbracoMacro Before performing transformation 0.00389319555647033 0.000052 
umbracoMacro After performing transformation 0.00408105443236593 0.000188 
item Start parsing 'metaDescription' 0.0041606121530321 0.000080 
item Done parsing 'metaDescription' 0.00423041763697145 0.000070 
item Start parsing 'metaKeywords' 0.00429355053788718 0.000063 
item Done parsing 'metaKeywords' 0.00433255948479447 0.000039 
item.recursive Item loaded from 1090 0.00439209945638979 0.000060 
item Start parsing 'siteName' 0.00441417030792944 0.000022 
item Done parsing 'siteName' 0.00445625890853993 0.000042 
item.recursive Item loaded from 1090 0.00453273697550289 0.000076 
item Start parsing 'siteName' 0.00455686092951135 0.000024 
item Done parsing 'siteName' 0.00458919729339502 0.000032 
umbracoMacro Macro loaded from cache (ID: 3, [.NET] Search Box) 0.00463436554770871 0.000045 
renderMacro Rendering started (macro: [.NET] Search Box, type: 3, cacheRate: 0) 0.00466567536035798 0.000031 
umbracoMacro Usercontrol added (/usercontrols/website/SearchBox.ascx) 0.00468877276313203 0.000023 
loadUserControl Usercontrol added with id 'SearchBox_2' 0.0049094812785285 0.000221 
umbracoMacro Macro loaded from cache (ID: 10, [XSLT] Navi) 0.00494797694981858 0.000038 
renderMacro Rendering started (macro: [XSLT] Navi, type: 1, cacheRate: 0) 0.00497210090382703 0.000024 
umbracoMacro Before adding extensions 0.00502188863869554 0.000050 
umbracoXsltExtension Extension added: urn:Exslt.ExsltCommon, ExsltCommon 0.00555158907564707 0.000530 
umbracoXsltExtension Extension added: urn:Exslt.ExsltDatesAndTimes, ExsltDatesAndTimes 0.00557622630527273 0.000025 
umbracoXsltExtension Extension added: urn:Exslt.ExsltMath, ExsltMath 0.00559932370804678 0.000023 
umbracoXsltExtension Extension added: urn:Exslt.ExsltRegularExpressions, ExsltRegularExpressions 0.00561882818150042 0.000020 
umbracoXsltExtension Extension added: urn:Exslt.ExsltStrings, ExsltStrings 0.00563781937933686 0.000019 
umbracoXsltExtension Extension added: urn:Exslt.ExsltSets, ExsltSets 0.0056562973015561 0.000018 
umbracoMacro After adding extensions 0.00567323539692373 0.000017 
umbracoMacro Before performing transformation 0.00569941245340099 0.000026 
umbracoMacro After performing transformation 0.00610695329345866 0.000408 
umbracoMacro Macro loaded from cache (ID: 17, [XSLT] Sub Navi) 0.00614955516968635 0.000043 
renderMacro Rendering started (macro: [XSLT] Sub Navi, type: 1, cacheRate: 0) 0.00619421014838285 0.000045 
umbracoMacro Before adding extensions 0.00624502443448576 0.000051 
umbracoXsltExtension Extension added: urn:Exslt.ExsltCommon, ExsltCommon 0.00675162746866324 0.000507 
umbracoXsltExtension Extension added: urn:Exslt.ExsltDatesAndTimes, ExsltDatesAndTimes 0.00677626469828889 0.000025 
umbracoXsltExtension Extension added: urn:Exslt.ExsltMath, ExsltMath 0.00679628244735974 0.000020 
umbracoXsltExtension Extension added: urn:Exslt.ExsltRegularExpressions, ExsltRegularExpressions 0.00681886657451658 0.000023 
umbracoXsltExtension Extension added: urn:Exslt.ExsltStrings, ExsltStrings 0.00683785777235302 0.000019 
umbracoXsltExtension Extension added: urn:Exslt.ExsltSets, ExsltSets 0.00685633569457226 0.000018 
umbracoMacro After adding extensions 0.0068732737899399 0.000017 
umbracoMacro Before performing transformation 0.00689893757079996 0.000026 
umbracoMacro After performing transformation 0.00700826527726379 0.000109 
item Start parsing 'pageName' 0.00704265474361626 0.000034 
item Done parsing 'pageName' 0.00708474334422675 0.000042 
item Start parsing 'headerText' 0.00711451333002442 0.000030 
item Done parsing 'headerText' 0.00714890279637689 0.000034 
umbracoMacro Macro loaded from cache (ID: 24, SForum) 0.007200230358097 0.000051 
renderMacro Rendering started (macro: SForum, type: 3, cacheRate: 0) 0.00722743396580866 0.000027 
umbracoMacro Usercontrol added (usercontrols/forum/forum.ascx) 0.0072495048173483 0.000022 
loadUserControl Usercontrol added with id 'forum_5' 0.00866614552082334 0.001417 
aspx.page End Init 0.00877290684920116 0.000107 
aspx.page Begin InitComplete 0.00879446442512361 0.000022 
aspx.page End InitComplete 0.00881294234734285 0.000018 
aspx.page Begin PreLoad 0.00882936716709328 0.000016 
aspx.page End PreLoad 0.00884527871122652 0.000016 
aspx.page Begin Load 0.00886170353097695 0.000016 
aspx.page End Load 0.108268818865548 0.099407 
aspx.page Begin LoadComplete 0.108313473844244 0.000045 
aspx.page End LoadComplete 0.108331951766464 0.000018 
aspx.page Begin PreRender 0.108348376586214 0.000016 
aspx.page End PreRender 0.114335223385248 0.005987 
aspx.page Begin PreRenderComplete 0.114371665954069 0.000036 
Unhandled Execution Error 
Object reference not set to an instance of an object.
  at DNA.UI.ClientScriptManager.RegisterScriptsOnPagePreRenderComplete(Object sender, EventArgs e)
  at System.EventHandler.Invoke(Object sender, EventArgs e)
  at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) 0.114743277500923 0.000372
Aug 9, 2010 at 1:21 AM
Hello I have no experience of YAF and I am going on holiday for two weeks this morning. 

So I recommend you use the our.umbraco.org forum

Thanks
Warren

On 5 Aug 2010, at 23:14, "mskurnik"<notifications@codeplex.com> wrote:

From: mskurnik

I was able to get YAF and umbraco to work together to a degree.  I added the <yaf:forum> tag to a usercontrol and I am trying to get it to display the forum inside of CWS.  CWS seems to be the issue but I am unable to track down exacly where the issue is.  If I use Runway the Forum embeds perfectly!

It has to be one of the scripts that are running with CWS but I can't figure one which one.  Has anyone had this problem

Here is the stack trace

  Server Error in '/' Application.
--------------------------------------------------------------------------------

Object reference not set to an instance of an object.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below. 

Stack Trace:

 

 

 

 


[NullReferenceException: Object reference not set to an instance of an object.]
   DNA.UI.ClientScriptManager.RegisterScriptsOnPagePreRenderComplete(Object sender, EventArgs e) +379
   System.EventHandler.Invoke(Object sender, EventArgs e) +0
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +4526

 


--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.1
Request Details
Session Id: 4gzg4hdtmwgmfljdqi5tlmuh Request Type: GET
Time of Request: 8/5/2010 11:56:45 AM Status Code: 500
Request Encoding: Unicode (UTF-8) Response Encoding: Unicode (UTF-8)
Trace Information
Category Message From First(s) From Last(s)
umbracoGlobalsettings reserverd urls: '/config/splashes/booting.aspx,/config/splashes/nonodes.aspx,/install/,/umbraco/,/yaf/,'  
aspx.page Begin PreInit 0.000530213712568734 0.000530
umbracoInit handling request 0.000569735935093219 0.000040
request handler current url '/forums.aspx' 0.000711913281057923 0.000142
umbracoRequestHandler Just before xPath query (True, '1156') 0.000744762920558793 0.000033
umbracoRequestHandler After xPath query 0.000767347047715641 0.000023
umbracoRequestHandler Access checking started 0.00080892237270893 0.000042
umbracoRequestHandler Page not protected 0.0008417720122098 0.000033
umbracoRequestHandler Access checking ended 0.000859736658811839 0.000018
umbracoInit Done handling request 0.000876674754179475 0.000017
umbracoPage Element loaded: umbracoNaviHide 0.00114511790197565 0.000268
umbracoPage Element loaded: headerText 0.00119439236122695 0.000049
umbracoPage Pagedata loaded for Forums (ID: 1156) 0.0012169764883838 0.000023
aspx.page End PreInit 0.00174873002780414 0.000532
aspx.page Begin Init 0.00177182743057819 0.000023
umbracoMacro Macro loaded from cache (ID: 13, [XSLT] Page Title) 0.00294979497205471 0.001178
renderMacro Rendering started (macro: [XSLT] Page Title, type: 1, cacheRate: 0) 0.00298418443840718 0.000034
umbracoMacro Before adding extensions 0.00305296337111213 0.000069
umbracoXsltExtension Extension added: urn:Exslt.ExsltCommon, ExsltCommon 0.00371765529538755 0.000665
umbracoXsltExtension Extension added: urn:Exslt.ExsltDatesAndTimes, ExsltDatesAndTimes 0.00374331907624761 0.000026
umbracoXsltExtension Extension added: urn:Exslt.ExsltMath, ExsltMath 0.00376385010093565 0.000021
umbracoXsltExtension Extension added: urn:Exslt.ExsltRegularExpressions, ExsltRegularExpressions 0.00378232802315489 0.000018
umbracoXsltExtension Extension added: urn:Exslt.ExsltStrings, ExsltStrings 0.00380080594537413 0.000018
umbracoXsltExtension Extension added: urn:Exslt.ExsltSets, ExsltSets 0.00382287679691378 0.000022
umbracoMacro After adding extensions 0.00384084144351582 0.000018
umbracoMacro Before performing transformation 0.00389319555647033 0.000052
umbracoMacro After performing transformation 0.00408105443236593 0.000188
item Start parsing 'metaDescription' 0.0041606121530321 0.000080
item Done parsing 'metaDescription' 0.00423041763697145 0.000070
item Start parsing 'metaKeywords' 0.00429355053788718 0.000063
item Done parsing 'metaKeywords' 0.00433255948479447 0.000039
item.recursive Item loaded from 1090 0.00439209945638979 0.000060
item Start parsing 'siteName' 0.00441417030792944 0.000022
item Done parsing 'siteName' 0.00445625890853993 0.000042
item.recursive Item loaded from 1090 0.00453273697550289 0.000076
item Start parsing 'siteName' 0.00455686092951135 0.000024
item Done parsing 'siteName' 0.00458919729339502 0.000032
umbracoMacro Macro loaded from cache (ID: 3, [.NET] Search Box) 0.00463436554770871 0.000045
renderMacro Rendering started (macro: [.NET] Search Box, type: 3, cacheRate: 0) 0.00466567536035798 0.000031
umbracoMacro Usercontrol added (/usercontrols/website/SearchBox.ascx) 0.00468877276313203 0.000023
loadUserControl Usercontrol added with id 'SearchBox_2' 0.0049094812785285 0.000221
umbracoMacro Macro loaded from cache (ID: 10, [XSLT] Navi) 0.00494797694981858 0.000038
renderMacro Rendering started (macro: [XSLT] Navi, type: 1, cacheRate: 0) 0.00497210090382703 0.000024
umbracoMacro Before adding extensions 0.00502188863869554 0.000050
umbracoXsltExtension Extension added: urn:Exslt.ExsltCommon, ExsltCommon 0.00555158907564707 0.000530
umbracoXsltExtension Extension added: urn:Exslt.ExsltDatesAndTimes, ExsltDatesAndTimes 0.00557622630527273 0.000025
umbracoXsltExtension Extension added: urn:Exslt.ExsltMath, ExsltMath 0.00559932370804678 0.000023
umbracoXsltExtension Extension added: urn:Exslt.ExsltRegularExpressions, ExsltRegularExpressions 0.00561882818150042 0.000020
umbracoXsltExtension Extension added: urn:Exslt.ExsltStrings, ExsltStrings 0.00563781937933686 0.000019
umbracoXsltExtension Extension added: urn:Exslt.ExsltSets, ExsltSets 0.0056562973015561 0.000018
umbracoMacro After adding extensions 0.00567323539692373 0.000017
umbracoMacro Before performing transformation 0.00569941245340099 0.000026
umbracoMacro After performing transformation 0.00610695329345866 0.000408
umbracoMacro Macro loaded from cache (ID: 17, [XSLT] Sub Navi) 0.00614955516968635 0.000043
renderMacro Rendering started (macro: [XSLT] Sub Navi, type: 1, cacheRate: 0) 0.00619421014838285 0.000045
umbracoMacro Before adding extensions 0.00624502443448576 0.000051
umbracoXsltExtension Extension added: urn:Exslt.ExsltCommon, ExsltCommon 0.00675162746866324 0.000507
umbracoXsltExtension Extension added: urn:Exslt.ExsltDatesAndTimes, ExsltDatesAndTimes 0.00677626469828889 0.000025
umbracoXsltExtension Extension added: urn:Exslt.ExsltMath, ExsltMath 0.00679628244735974 0.000020
umbracoXsltExtension Extension added: urn:Exslt.ExsltRegularExpressions, ExsltRegularExpressions 0.00681886657451658 0.000023
umbracoXsltExtension Extension added: urn:Exslt.ExsltStrings, ExsltStrings 0.00683785777235302 0.000019
umbracoXsltExtension Extension added: urn:Exslt.ExsltSets, ExsltSets 0.00685633569457226 0.000018
umbracoMacro After adding extensions 0.0068732737899399 0.000017
umbracoMacro Before performing transformation 0.00689893757079996 0.000026
umbracoMacro After performing transformation 0.00700826527726379 0.000109
item Start parsing 'pageName' 0.00704265474361626 0.000034
item Done parsing 'pageName' 0.00708474334422675 0.000042
item Start parsing 'headerText' 0.00711451333002442 0.000030
item Done parsing 'headerText' 0.00714890279637689 0.000034
umbracoMacro Macro loaded from cache (ID: 24, SForum) 0.007200230358097 0.000051
renderMacro Rendering started (macro: SForum, type: 3, cacheRate: 0) 0.00722743396580866 0.000027
umbracoMacro Usercontrol added (usercontrols/forum/forum.ascx) 0.0072495048173483 0.000022
loadUserControl Usercontrol added with id 'forum_5' 0.00866614552082334 0.001417
aspx.page End Init 0.00877290684920116 0.000107
aspx.page Begin InitComplete 0.00879446442512361 0.000022
aspx.page End InitComplete 0.00881294234734285 0.000018
aspx.page Begin PreLoad 0.00882936716709328 0.000016
aspx.page End PreLoad 0.00884527871122652 0.000016
aspx.page Begin Load 0.00886170353097695 0.000016
aspx.page End Load 0.108268818865548 0.099407
aspx.page Begin LoadComplete 0.108313473844244 0.000045
aspx.page End LoadComplete 0.108331951766464 0.000018
aspx.page Begin PreRender 0.108348376586214 0.000016
aspx.page End PreRender 0.114335223385248 0.005987
aspx.page Begin PreRenderComplete 0.114371665954069 0.000036
Unhandled Execution Error
Object reference not set to an instance of an object.
  at DNA.UI.ClientScriptManager.RegisterScriptsOnPagePreRenderComplete(Object sender, EventArgs e)
  at System.EventHandler.Invoke(Object sender, EventArgs e)
  at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) 0.114743277500923 0.000372

Aug 23, 2010 at 6:13 PM

Hello mskurnik,
Did you manage to solve this problem or can I be of any assistance still?

Thanks,
Warren :)

Aug 23, 2010 at 6:39 PM

Sort of.  There is something that doesn’t like the inclusion of YAF in a web.  I ended up copying the CWS master theme to a new master and including YAF directly that way.  It is not ideal as I have to update both masters if I make a change.

At least it works.

Thank you!

From: warrenbuckley [mailto:notifications@codeplex.com]
Sent: Monday, August 23, 2010 10:14 AM
To: mskurnik@gmail.com
Subject: Re: Umbraco, YAF, & CWS [umbracocws:222648]

From: warrenbuckley

Hello mskurnik,
Did you manage to solve this problem or can I be of any assistance still?

Thanks,
Warren :)

Read the full discussion online.

To add a post to this discussion, reply to this email (umbracocws@discussions.codeplex.com)

To start a new discussion for this project, email umbracocws@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com

Aug 24, 2010 at 9:41 AM

Hi Mskurnik,
What is the differences between the masterpages and how they are embedded?

Thanks,
Warren :)

Aug 24, 2010 at 5:43 PM

I created a root master page called BBS and added <umbraco:Macro Alias="SForum" runat="server"></umbraco:Macro> 

I then created a user control in usercontrols/forum/forum.ascx

Code behind:

    protected void Page_Load(object sender, EventArgs e)

    {

        Exception x = Server.GetLastError();

        YAF.Classes.Data.DB.eventlog_create(YafServices.InitializeDb.Initialized ? (int?)YafContext.Current.PageUserID : null, this, x);

        YAF.Classes.Core.CreateMail.CreateLogEmail(x);

    }

Ascx page

<%@ Control Language="C#" Debug="true" AutoEventWireup="true" CodeFile="forum.ascx.cs" Inherits="usercontrols_forum" %>

<%@ Register TagPrefix="YAF" TagName="ForumWelcome" Src="~/controls/ForumWelcome.ascx" %>

<%@ Register TagPrefix="YAF" TagName="ForumIconLegend" Src="~/controls/ForumIconLegend.ascx" %>

<%@ Register TagPrefix="YAF" TagName="ForumStatistics" Src="~/controls/ForumStatistics.ascx" %>

<%@ Register TagPrefix="YAF" TagName="ForumActiveDiscussion" Src="~/controls/ForumActiveDiscussion.ascx" %>

<%@ Register TagPrefix="YAF" TagName="ForumCategoryList" Src="~/controls/ForumCategoryList.ascx" %>

<%@ Register TagPrefix="YAF" TagName="ShoutBox" Src="~/controls/ShoutBox.ascx" %>

<YAF:Forum runat="server" id="forums" ViewStateMode="Enabled" BoardID="1" Visible="true" />

I then created a pages called Message Boards and set the template to BBS.

I also added a url redirect

<add name="YafRewrite" virtualUrl="forums.aspx(.*)" rewriteUrlParameter="ExcludeFromClientQueryString" destinationUrl="Message-Boards.aspx?$1" ignoreCase="true" />

When adding the Macro to the template I created it works just fine.

But if I add that macro to a sub template such as textpage, I get error after error

From: warrenbuckley [mailto:notifications@codeplex.com]
Sent: Tuesday, August 24, 2010 1:42 AM
To: mskurnik@gmail.com
Subject: Re: Umbraco, YAF, & CWS [umbracocws:222648]

From: warrenbuckley

Hi Mskurnik,
What is the differences between the masterpages and how they are embedded?

Thanks,
Warren :)

Read the full discussion online.

To add a post to this discussion, reply to this email (umbracocws@discussions.codeplex.com)

To start a new discussion for this project, email umbracocws@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com

Aug 25, 2010 at 8:35 AM

Hi Mskurnik,
OK so the only difference is that
<umbraco:Macro Alias="SForum" runat="server"></umbraco:Macro>  is in a nested masterpage.

Have you tried creating a new child masterpage specifically for the forum that inherits from the master.master and then inserting your macro to see if that makes any difference.
If that does not work check the master.master for a codebehind file (been a while since I have dug in my code, and see if there would be anything in there could conflict with your forum code)

Warren

Aug 25, 2010 at 8:36 AM

Yeah, I tried that.  I could not figure out what was conflicting.

From: warrenbuckley [mailto:notifications@codeplex.com]
Sent: Wednesday, August 25, 2010 12:36 AM
To: mskurnik@gmail.com
Subject: Re: Umbraco, YAF, & CWS [umbracocws:222648]

From: warrenbuckley

Hi Mskurnik,
OK so the only difference is that
<umbraco:Macro Alias="SForum" runat="server"></umbraco:Macro> is in a nested masterpage.

Have you tried creating a new child masterpage specifically for the forum that inherits from the master.master and then inserting your macro to see if that makes any difference.
If that does not work check the master.master for a codebehind file (been a while since I have dug in my code, and see if there would be anything in there could conflict with your forum code)

Warren

Read the full discussion online.

To add a post to this discussion, reply to this email (umbracocws@discussions.codeplex.com)

To start a new discussion for this project, email umbracocws@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com

Aug 25, 2010 at 8:39 AM

Sorry I am running out of ideas. I recommend you DEBUG the site with visual studio and add break points and step through the code to see what is going on.

If you do ever find out the problem I would be more than happy to know please.

Thanks,
Warren

Aug 25, 2010 at 8:43 AM

If it helps this is what the solution was and the debugging steps I took:

http://our.umbraco.org/forum/getting-started/installing-umbraco/11233-Umbraco-and-YAF?p=0

From: warrenbuckley [mailto:notifications@codeplex.com]
Sent: Wednesday, August 25, 2010 12:40 AM
To: mskurnik@gmail.com
Subject: Re: Umbraco, YAF, & CWS [umbracocws:222648]

From: warrenbuckley

Sorry I am running out of ideas. I recommend you DEBUG the site with visual studio and add break points and step through the code to see what is going on.

If you do ever find out the problem I would be more than happy to know please.

Thanks,
Warren

Read the full discussion online.

To add a post to this discussion, reply to this email (umbracocws@discussions.codeplex.com)

To start a new discussion for this project, email umbracocws@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com

Aug 25, 2010 at 8:56 AM

I had a very quick skim through this forum thread and it seems that the user has not wrapped in an umbraco:macro but embedding the control directly in the masterpage.

<%@ Master Language="C#" MasterPageFile="~/masterpages/RunwayMaster.master" AutoEventWireup="true" %>
<%@ Register TagPrefix="YAF" Assembly="YAF" Namespace="YAF" %>
 
<asp:Content ContentPlaceHolderID="RunwayMasterContentPlaceHolder" runat="server">
  <div ID="yafForum">
    <YAF:Forum runat="server" ID="forum" />
  </div>
</asp:Content>

Aug 25, 2010 at 9:03 AM

I tried that and it still breaks with the same error…

From: warrenbuckley [mailto:notifications@codeplex.com]
Sent: Wednesday, August 25, 2010 12:57 AM
To: mskurnik@gmail.com
Subject: Re: Umbraco, YAF, & CWS [umbracocws:222648]

From: warrenbuckley

I had a very quick skim through this forum thread and it seems that the user has not wrapped in an umbraco:macro but embedding the control directly in the masterpage.

<%@ Master Language="C#" MasterPageFile="~/masterpages/RunwayMaster.master" AutoEventWireup="true" %>
<%@ Register TagPrefix="YAF" Assembly="YAF" Namespace="YAF" %>

<asp:Content ContentPlaceHolderID="RunwayMasterContentPlaceHolder" runat="server">

<YAF:Forum runat="server" ID="forum" />

</asp:Content>

Read the full discussion online.

To add a post to this discussion, reply to this email (umbracocws@discussions.codeplex.com)

To start a new discussion for this project, email umbracocws@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on CodePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at CodePlex.com

Aug 25, 2010 at 9:16 AM

Sorry I dont think I will be able to help any further. I recommend you try the main our.umbraco.org forum to see if you get any assistance.
But was you aware of the uForum package which is designed for Umbraco.